hub install error: cannot create instance to NimBUS
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hub install error: cannot create instance to NimBUS

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Article ID: 130328

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Unable to install secondary Hub, receiving error and installation does not complete. 

Popup error is displayed:

Initial Security

Cannot create instance to NimBUS.

Check is 'nimbus.dll' is properly registered.

hub install fails on Windows OS after reaching 99%.

Environment

  • Release: Any
  • Component: UIMHUB

Cause

- Most likely AntiVirus

Resolution

Make sure you first install the

   vs2017_vcredist_x64

   vs2017_vcredist_x86

packages from the local archive.

Then rerun the installer, rt-click-> Run As Administrator.

If the steps above dont resolve the issue, follow the steps below:

Always make sure that any AntiVirus/Security software is temporarily disabled before the installation/upgrade.


To restablish/reinstall the Nimsoft Robot Watcher Service, issue the following commands via the Windows command prompt.

Start the command prompt via rt-click "Run as Administrator"

Then issue the commands shown below to ninstall and reinstall the Nimsoft Robot Watcher Service, for example:

C:\Windows\system32>sc delete NimbusWatcherService binPath="C:\Program Files (x86)\Nimsoft\bin\nimbus.exe" DisplayName="Nimsoft Robot Watcher" start=delayed-auto
[SC] DeleteService SUCCESS

C:\Windows\system32>sc create NimbusWatcherService binPath="C:\Program Files (x86)\Nimsoft\bin\nimbus.exe" DisplayName="Nimsoft Robot Watcher" start=delayed-auto
[SC] CreateService SUCCESS

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