iConsole server is not producing logs

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Article ID: 130300

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Updated On:

Products

SINGLE SIGN ON - LEGACY CA Data Protection (DataMinder) CA User Activity Reporting

Issue/Introduction

CA Data Protection iConsole server is not creating any new log files.  Logs can be successfully written to the NT logs but nothing is produced in the %wgndatadir%\logs folder.

Cause

This issue is caused by a lack of Windows permissions.

The Windows Event log records:

The log module "iConsole" has failed to open its log file "D:\ProgramData\CA\CA DataMinder\data\log\iConsole_20190201000019.log". Error is "0x80070005 (Access is denied. )".

Environment

CA Data Protection 14.x\ 15.x

Resolution

Adding the "NETWORK SERVICE" account to the log folder results in normal iConsole logging.

Additional Information

Orchestria, Orchestria APM, CA DLP and CA DataMinder are all previous brand names for the product now known as CA Data Protection