Unable to start the CAPC console and sso services

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Article ID: 130266

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Updated On:

Products

CA Infrastructure Management CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

Unable to start CAPC caperfcenter_console and caperfcenter_sso services. The following error can be seen within the PCService.log:

Caused by: java.lang.IllegalArgumentException: Invalid uri 'http://<Recovery/New DA IP Address>:8581/consul': Invalid authority

Cause

The following script was run within CAPC:
 
/opt/CA/PerformanceCenter/Tools/bin/update_pc_da_database_references.sh

This caused the unchanged options within the script to overwrite the proper hostnames and ip addresses within the database.

Environment

Release:
Component: CAPRFC

Resolution

Correctly configure the script entries at the top and execute it again to set the values back.  Please note, you need to leave the double quotes there in these settings and just remove the sections between and including < >.

The following section is the only configurable settings within the script

##################################################################
# UPDATE THE FOLLOWING PC/DA VARIABLES TO REFLECT NEW ENVIRONMENT
##################################################################
NEW_PC_IP_ADDRESS="<Recovery/New PC IP Address>"
NEW_PC_HOSTNAME="<Recovery/New PC Hostname>"
NEW_PC_EVENT_PRODUCER_PORT=8181
NEW_PC_EVENT_PRODUCER_PROTOCOL="http" # change to "https" if using SSL

NEW_DA_IP_ADDRESS="<Recovery/New DA IP Address>"
NEW_DA_HOSTNAME="<Recovery/New DA Hostname>"
NEW_DA_PORT_NUMBER=8581

MYSQL_USER="netqos"
MYSQL_PASSWORD="netqos"
 

Additional Information

For more information please refer to the documentation on this script at the below URL:

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/performance-management/3-6/administrating/disaster-recovery.html