Same MS SQL backend appears as differents in Team Center map
book
Article ID: 130237
calendar_today
Updated On:
Products
CA Application Performance Management Agent (APM / Wily / Introscope)INTROSCOPE
Issue/Introduction
The .Net agent is discovering as different backend, the same MS SQL 2008 R2 DB instance. The only difference between the duplicates is the name which come in uppercase/lowercase or mix of both
Environment
MOM/Collector # CA Wily Introscope(R) Version 10.7.0 Release 10.7.0.45 # Hotfix 10.7.0-HF14
.Net Agent # Introscope AutoProbe and Agent Configuration # CA Wily Introscope(R) Version 10.7.0 Release 10.7.0.115
Cause
The backend is recognized as different backends, due the name is some times discovered as with all letters in upper case, or all in lower case , or a mix of both. Example: USERS, Users, users, etc
Resolution
SE built a Desktop Build wily.SQLAgent.ext.dll_DE406681_10.7.0.115DesktopBuild20190306.zip This Desktop Build set the DB name in lower case, hence it is recognized as the same The definitive HF solution was included in 10.7 HF #31