Issue upgrading Workload Automation AE to 11.3.6 SP7

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Article ID: 130233

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation Agent

Issue/Introduction

 While upgrading from  WAAE 11.3.6 SP5 to SP7 it shows new install page instead of upgrade. it was not detecting the existing install

Cause

The details regarding the current install is stored in the PIF database. Since the lsm binary was missing the install was not able to detect the existing  Workload Automation AE install.

Environment

Workload Automation AE 11.3.6 SP5 HA with Oracle on RAC on Linux

Resolution

The patch installer was run as root. Observed that lsm binary was missing. It was identified by running lsm -l|grep Workload, which gave the output as command not found.
The details regarding the current install is stored in the PIF database. Since the lsm binary was missing the install was not able to detect the existing  Workload Automation AE install.

Installed lsm by running ca-sm-installer from the product DVD.

We ran the command 'lsm -l | grep Workload ' and it was showing the installed version. After that we were able to run the patch installer successfully.

Additional Information

https://docops.ca.com/ca-workload-automation-ae/11-4-2/en/installing/ca-common-components-installation/lsm-command-manage-unix-products-on-target-computers