Error Message "ciGetCachePath - NIM_ROOT not set"
search cancel

Error Message "ciGetCachePath - NIM_ROOT not set"

book

Article ID: 130223

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

In the data_engine.log file we are getting the error message:

ciGetCachePath - NIM_ROOT not set!

 

Environment

UIM 8.x
UIM 9.x

Cause

The  NIM_ROOT environment variable is not set in the controller configuration (Setup->Environment Tab).
 

Resolution

.Please set NIM_ROOT=<$nimroot of robot installation> as an environment variable in the controller configuration (Setup->Environment Tab).
After changing this, restart the robot so the environment variables are getting reloaded.