VMware probe memory utilization calculation and qos metrics do not match with vSphere data
search cancel

VMware probe memory utilization calculation and qos metrics do not match with vSphere data

book

Article ID: 130218

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Memory utilization value of a server in UIM is not matching up with the value showing on the server. We are monitoring these servers using the vmware probe.

Environment

  • UIM 8.x, 9.x
  • vmware probe

Cause

  • Different collection interval, number of samples collected, units (memory consumed in GB versus physical memory percentage), and averaging in the vmware probe versus the vSphere client.

Resolution

VM Memory Usage QOS is calculated by averaging the values of counter 'usage' in the past 10 mins (resource data collection interval).

In vCenter, a new counter value is available every 20 seconds, thus we get 30 values for the counter in 10 mins, and it's average value becomes the QOS value at that point of time.

In vSphere client, we see the performance graph for the above counter based on the latest values. The average value of the counter is also available but the duration for which the average is calculated will not match the duration for which the probe calculates the average - thus the values may not be an exact match.