Missing Time report missing data when DAILYRESOURCEAVAIL does not cover the entire period(s)
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Missing Time report missing data when DAILYRESOURCEAVAIL does not cover the entire period(s)

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Article ID: 130054

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The Missing Time Report does not work as expected / correctly if there is no resource availability.

For example, the week on the report should display a total of 40 Available hours per resource, but instead, it is only showing 16 hours. 

Environment

Release: All
Component: Clarity Jaspersoft

Cause

Since the report looks at the daily resource availability it cannot produce correct results if those time slices are not available.
As referenced at Missing Time

The resource available hours are calculated based on the time slice with the name DAILYRESOURCEAVAILCURVE (Administration/Data Administration-Time Slices). This time slice is not a Data Warehouse request, therefore, it must be configured to cover the dates that are displayed in this report or the report does not display data for those dates.

Resolution

Set the DAILYRESOURCEAVAIL slice back to cover at least the entire time period of your report. In the example mentioned above, the 16 hours are getting calculated because this slice is set to start on a Thursday instead of the first day of the week. Since in this example an availability time slice only exists for Thursday and Friday, this is where the 16 hours are coming from. 

Note that the DAILYRESOURCEAVAIL slice rolls over monthly so make sure you set it back far enough to cover the monthly rollover.

Additional Information

Reference also: Jaspersoft / reports known issues with Clarity