Running data collector not seen in CAPC console

book

Article ID: 130046

calendar_today

Updated On:

Products

CA Infrastructure Management

Issue/Introduction

A running data collector is not seen in the data collector list in the CAPC user interface.  A similiar error would be seen in the data collector karaf.log
 

org.ops4j.pax.logging.pax-logging-api - 1.8.3 |  | Error resolving artifactcom.ca.im:data-mgmt.provision:xml:features:3.6.2-RELEASE-360:Could not find artifact com.ca.im:data-mgmt.provision:xml:features:3.6.2-RELEASE-360

shaded.org.eclipse.aether.resolution.ArtifactResolutionException: Could not find artifact com.ca.im:data-mgmt.provision:xml:features:3.6.2-RELEASE-360

at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444)

at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)

at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223)

at shaded.org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:294)

at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:574)

at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:528)

at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:506)

at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:481)

at org.ops4j.pax.url.mvn.internal.Connection.getInputStream(Connection.java:123)

at org.apache.karaf.features.internal.FeatureValidationUtil.validate(FeatureValidationUtil.java:55)[7:org.apache.karaf.features.core:2.4.3]

at org.apache.karaf.features.internal.FeaturesServiceImpl.validateRepository(FeaturesServiceImpl.java:213)[7:org.apache.karaf.features.core:2.4.3]

at org.apache.karaf.features.internal.FeaturesServiceImpl.internalAddRepository(FeaturesServiceImpl.java:255)[7:org.apache.karaf.features.core:2.4.3]

at org.apache.karaf.features.internal.FeaturesServiceImpl.start(FeaturesServiceImpl.java:1365)[7:org.apache.karaf.features.core:2.4.3]

at org.apache.karaf.features.osgi.Activator.doStart(Activator.java:126)[7:org.apache.karaf.features.core:2.4.3]

at org.apache.karaf.features.osgi.Activator$2.addingService(Activator.java:96)[7:org.apache.karaf.features.core:2.4.3]

at org.apache.karaf.features.osgi.Activator$2.addingService(Activator.java:93)[7:org.apache.karaf.features.core:2.4.3]

at org.osgi.util.tracker.ServiceTracker$Tracked.customizerAdding(ServiceTracker.java:932)[karaf.jar:2.4.3]

at org.osgi.util.tracker.ServiceTracker$Tracked.customizerAdding(ServiceTracker.java:1)[karaf.jar:2.4.3]

at org.osgi.util.tracker.AbstractTracked.trackAdding(AbstractTracked.java:256)[karaf.jar:2.4.3]

at org.osgi.util.tracker.AbstractTracked.trackInitial(AbstractTracked.java:183)[karaf.jar:2.4.3]

at org.osgi.util.tracker.ServiceTracker.open(ServiceTracker.java:317)[karaf.jar:2.4.3]

at org.osgi.util.tracker.ServiceTracker.open(ServiceTracker.java:261)[karaf.jar:2.4.3]

at org.apache.karaf.features.osgi.Activator.start(Activator.java:111)[7:org.apache.karaf.features.core:2.4.3]

at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)

at java.security.AccessController.doPrivileged(Native Method)[:1.8.0_161]

at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)[osgi-3.9.1-v20140110-1610.jar:]

at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)[osgi-3.9.1-v20140110-1610.jar:]

Caused by: shaded.org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact com.ca.im:data-mgmt.provision:xml:features:3.6.2-RELEASE-360

Cause

missing bundles

Environment

CAPM 3.x

Resolution

To resolve, check to see if /opt/IMDataCollector/.maven_repository is there.  If it is not, then the bundles are missing and the data collector must be "over" installed.  Note, you do not have to uninstall / reinstall.  Simply over installing the data collector should lay down the .maven_repository as well as the bundles.  If it does not, check for install failures or permissions issues.