Does APM On-Premise Java Agent support Java 9-11?

book

Article ID: 129997

calendar_today

Updated On:

Products

CA Application Performance Management SaaS CA Application Performance Management (APM / Wily / Introscope) CA Application Performance Management Agent (APM / Wily / Introscope) INTROSCOPE

Issue/Introduction

Does APM On-Premise Agent support Java 9-11?

Environment

APM 10.7 and SaaS

Resolution

1) Java 9 and 11 are only supported for APM SaaS agents

As of October 2020, there are no plans to backport the Java 11 support to 10.7. The best option for customers is to use the latest agent from APM saas.


2) You can use APM SaaS Agents with either the APM SaaS or APM onPremise 10.7 EM.

There are separate instructions to use with Java 9 to 11.

For Application using Java 8 and previous versions:

 -javaagent:$AGENT_HOME/Agent.jar -DagentProfile=$AGENT_HOME/core/config/IntroscopeAgent.profile

For Application using Java 9 and higher versions:

 -javaagent:$AGENT_HOME/Agent.jar -DagentProfile=$AGENT_HOME/core/config/IntroscopeAgent.profile --add-exports java.instrument/sun.instrument=ALL-UNNAMED --add-exports jdk.management/com.sun.management.internal=ALL-UNNAMED --patch-module java.base=$AGENT_HOME/common/AgentSocket.jar

 

Additional Information

How to configure DXI APM SaaS agents or DX APM Onpremise 11.x, 19.x, 20.x to connect to 10.7 On-premise?
https://knowledge.broadcom.com/external/article/142917