QnA Strike count shown as minus 2 on the Admin UI screens

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Article ID: 129924

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Updated On:

Products

CA Rapid App Security CA Advanced Authentication CA API Gateway

Issue/Introduction

At version 9.0 when a QnA is fetched and the Authentication is not performed the StrikeCount (which represents the failed attempts) is set to a "-2". These two screens will show the "-2" value. 

1. The "Manage Authentication Credential" screen of the Global Admin UI shows "Number of Failed Attempts" as "-2" which is meaningless to the user. In previous versions the failed attempts was always shown as 0 or higher positive number.

<Please see attached file for image>

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2. In the "Authentication Activity Report"  (using the Global Admin's Reports function) you can see that "Failed Attempts" column is displaying a "-2".

<Please see attached file for image>

User-added image

Cause


This was a bug introduced that displayed "Failed Attempts" (Strike Count) as an internal raw state of the QnA credential. This raw state was not meaningful to the user with respect to the failed attempts

In the backed DB, "-2" for Failed Attempt related field was used by CA Strong Authentication to represent the QnA credential state where QnA was fetched but a Authentication was not attempted using the fetched QnA credential. For any display a "-2" is meaningless hence has neen corrected. 

 

Environment

CA Strong Authentication version 9.0

Resolution

Please request these two patch related files from Broadcom Support Team

1. CA-StrongAuth-9.0-DE392185-HotFix-Release-Notes.txt
2. CA-StrongAuth-9.0-DE392185-HotFix.zip

Additional Information

None.

Attachments

1558688483057000129924_sktwi1f5rjvs16fmg.jpeg get_app
1558688479885000129924_sktwi1f5rjvs16fmf.jpeg get_app