Investment Allocation / Portfolio Sync fails: ORA-03106: fatal two-task communication protocol
search cancel

Investment Allocation / Portfolio Sync fails: ORA-03106: fatal two-task communication protocol

book

Article ID: 129660

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

One or more jobs intermittently fails with error ORA-03106: fatal two-task communication protocol error in Clarity. Jobs that fail with this error include: Investment Allocation Job, Portfolio Sync, Post Timesheets job

Error found in bg-ca.logs:

ERROR 2019-03-13 19:00:02,676 [Dispatch Investment Allocation : [email protected] (tenant=clarity)] niku.njs (clarity:admin:.....:Investment Allocation) Error executing job: 5034781 java.lang.RuntimeException: java.sql.SQLException: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-03106: fatal two-task communication protocol error at com.niku.projmgr.service.staffing.job.InvestmentAllocationJob.scheduledEventFired(InvestmentAllocationJob.java:100) at com.niku.njs.Dispatcher$BGTask.run(Dispatcher.java:657) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748) Caused by: java.sql.SQLException: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-03106: fatal two-task communication protocol error

Environment

Release: All Supported Releases

Component: Clarity Environment

Cause

This issue is caused by DE49805

Resolution

This issue is targeted to be fixed in Clarity 15.9. For a fix on prior versions (where the workarounds below do not work, please reach out to Broadcom Support for a fix for this issue. 

Workarounds:

  1. Run the job more than once per day (recommended during outside business hours where possible), as the amount of times it is run increases the probability of at least one successful run per day.

        Notes:

    • The Investment allocation job is one that is normally recommended to be run only once daily as it does process all investments, so this would be a temporary workaround. See KB How often should I run the Investment Allocation Job? for more details.
    • If a XOG write action is perform for updating an existing project, the action triggers slicing and the execution of the Investment Allocation job for the specific projects so that the project manager is able to immediately see all updated data on the projects updated from that action without having to manually execute the job for all investments.
    • To check the scheduled frequency: 
      1. Navigate to the Home > Reports and Jobs > Scheduled jobs page.
      2. Find out the frequency of the Investment Allocation job.

     2. Check to see if there are any other jobs running at the same time when the issue occurs. It's recommended at a minimum to make the Investment Allocation job incompatible with the Time Slicing job.

To check if the jobs are already incompatible:

  1. Go to Administration > Data Administration > Reports and Jobs
  2. Click on the Investment Allocation job
  3. Click on the Incompatible Jobs tab

On Premise customers: You can also check the job's incompatibility list with the below query:

select
I.JOB_DEFINITION_ID,
I.NON_CONCUR_JOB_DEF_ID,
k.job_code
FROM
CMN_SCH_JOB_NONCONCUR I,
CMN_SCH_JOB_DEFINITIONS J,
CMN_SCH_JOB_DEFINITIONS K
Where I.Job_Definition_Id = J.Id
and I.NON_CONCUR_JOB_DEF_ID = K.id
and J.JOB_CODE in ('inv_alloc_job')
order by J.JOB_CODE

Additional Information