UIM - Database Errors after login to Infrastructure Manager
search cancel

UIM - Database Errors after login to Infrastructure Manager

book

Article ID: 129633

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I see the following errors when I login to Infrastructure Manager

Database error: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified
DB operation failed

Environment

- UIM 9.02

Cause

- an outdated nimbus.dll

Resolution

The patch has to be applied manually by replacing the binary(nimbus.dll). Please follow the below steps.

  • Close the Infrastructure Manager application
  • Go to “C:\Program Files (x86)\Nimsoft\lib”. Take a backup of the file nimbus.dll by moving to another folder
  • Copy the updated nimbus.dll to “C:\Program Files (x86)\Nimsoft\lib”
  • On command prompt, run the following command to register the DLL

                   regsvr32 "C:\Program Files (x86)\Nimsoft\lib\nimbus.dll"

  • For standalone IM installation, copy the “security” folder from any robot/hub to “C:\Program Files (x86)\Nimsoft”.
    • Make sure the file certificate.pem is present in the “security” folder. If IM is installed on robot/hub, the security folder should already be present.
  • Start IM GUI and verify no errors are seen in the message window

NOTE: In the above steps, replace “C:\Program Files (x86)\Nimsoft" with the appropriate path where IM is installed.

If IM is installed on the hub, then there will be two nimbus.dll's - one in the hub install folder and another in the IM install folder. Please perform the above steps on the IM install folder.

nimbus.dll is attached to this article.

Additional Information

Important Notes:

The message is not really indicating any product fault. Actually, this message was always present since earlier versions (NMS 7.x). 

In some cases we have seen that the fix dll does not fix those messages even in UIM 9.2 and UIM 20.1, It is also expected that we may see those messages in IM in UIM 20.3 too. 

We may also still see the error despite the updated nimbus.dll is deployed when using mysql and oracle.

Also we have seen this error with newer versions of MSSQL or with TLS enabled.

The Infrastructure Manager code is closed and new technology supported by UIM are not really supported by the IM, which may throw those errors that can be safely ignored. 

Messages showing in the deprecated IM "message window" can be safely ignored.

Attachments

1622666327009__nimbus.dll get_app