CAPC_item_ID attribute not being written into attribute section of the model in Spectrum
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CAPC_item_ID attribute not being written into attribute section of the model in Spectrum

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Article ID: 129620

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Updated On:

Products

Spectrum

Issue/Introduction

The CAPC_item_ID attribute is not being populated in Spectrum.   The item_model_mapping table has been truncated on the netqos_integ db in OC but if the issue keeps coming back.

How can we troubleshoot? 

 

 

Environment

CA Spectrum integrated with CA Performance Manager on any version

Cause

For this attribute to be populated in OneClick, the device exists in an IPdomain in Oneclick, regardless of how it was added.

i.e. either from Spectrum side or from a synch with an existing device on NetOps Portal side (i.e. device is written into item mapping table in netqos_integ database).

Resolution

Please enable following debug logs from Spectrum Administration debug page. 

Performance Center Integration 
Performance Center Integration Sync 

Recreate problem, either delete the device in Spectrum and readd or truncate the pollers table and wait for it to be populated.
Turn off debug.

From Spectrum

Collect OneClick  tomcat log and output of the following commands for the devices it is not working in spectrum

1. vnmsh command to retrieve CAPC_item_id
./show attributes attr=0x13214 mh=(hex value of the device model handle) 

2. Spectrum mysql query 

log into mysql on the Oneclick (integrated with NetOps Portal) from /Spectrum/mysql/bin 

./mysql --defaults-file=../my-spectrum.cnf -uroot -p<password> netqos_integ;  


select * from item_model_mapping where model_handle = (model handle of device in question); 

 3. Generate and collect NetOps Portal side CARE logs 

4. Upload to a support issue.

Additional Information