RPT-0023 error when trying to run Jaspersoft report
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RPT-0023 error when trying to run Jaspersoft report

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Article ID: 129599

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When running an Out-of-the-box (OOTB) report from Home > Advanced Reporting or Reports and jobs, the following error is received:
RPT-0023: The user does not exist on reporting server or incorrect login credentials or server may be down. Please contact your system administrator.

Environment

Release:  All
Component: Clarity Jaspersoft Reporting

Cause

The Clarity user could not be authenticated in the Jaspersoft users database.

Resolution

Step 1: Change the folder-level access for ROLE_USER

If you are seeing this issue post upgrading, see the below from Post-Upgrade Folder Level and User Level Security

After the upgrade, the folder-level or user-level security can get reset by the installer.

  1. To check if a user has the required rights, log in to Clarity Advance Reporting with an account that does not have administrative access.
  2. In Release 15.3 or higher, test the reports by clicking Home, Reports, and Jobs and launching any default report.
  3. If you encounter the RPT-0023 error, folder-level access permissions have been reset.
  4. To fix this problem, change the folder-level access for ROLE_USER from No Access to Read Only.

Note: After the folder-level access has been changed, run the "Create and Update Jaspersoft Users" Job 

Step 2: Check Clarity permissions

If the above doesn't help, perform the below steps:

  1. Assign the Global Right "Advanced Reporting - Navigate" to the Resource
  2. Add the user to the following group in Clarity: PMO Advanced Reporting Resource Management (If running Resource Management reports)
  3. Run the below jobs in the below order:
    1. Create and Update Jaspersoft Users
    2. Synchronize Jaspersoft Roles

Additional Information

See also: Jaspersoft / reports known issues with Clarity