New UX Error: PMO Accelerator must be installed to use Status Reports

book

Article ID: 129537

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

New User Experience (UX) Error: "PMO Accelerator must be installed to use Status Reports". This error is showing when the New UX is opened in Clarity PPM.

Environment

Release:
Component: PMO

Resolution

PMO Accelerator is not installed or not fully applied.

Check to make sure the PMO Accelerator is installed for Clarity PPM.
To do this, run the following query on the Clarity database:

select * from cmn_install_history order by installed_date desc

Look for the 'csk' entry, it should be the same version as your Clarity version. If it's not:

1. Install PMO Accelerator:

a. Get some downtime scheduled on your environment

b. Run the command on the Clarity server:

admin content csk

c. Once it's completed, go to Content Addins - Items and see if you can apply everything but the Views.

Then try again and it should work.



2. Additionally, even if the installation of the addin was successful, if the PMO installation status in Clarity PPM is not showing as "Installed" this error can be generated.

    • To check if this is the case, in Clarity go to Administration->Studio->Content Add-Ins->Accelerator: Program Management Office
    • If the status doesn't show as "Installed", check for any items in the Items tab for the PMO Accelerator that are in Not Installed status and manually install them. 

                     IMPORTANT: Before upgrading any items, make sure there is no impact to any customizations in the system (such as views) that would get overwritten when upgrading the items. We recommend as best practice to apply any non-Views items first. Installing the PMO Views will remove user views customizations, and must only be done if this is not considered to be an issue