CA AXA LDAP live and historical data not available

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Article ID: 129480

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Updated On:

Products

CA App Experience Analytics

Issue/Introduction

After originally configuring AXA to use the local userstore, it was then reconfigured to use the LDAP userstore.
It is still possible to login using the LDAP userstore tenant but no live data is reporting and there is no historical data in Analytics or Data Studio

Cause

When the LDAP userstore is configured, it creates a new cohort internally which is a new tenant. All of the previous app configuration, sessions will not be visible in the LDAP user store.
Similarly, data gathered under the LDAP userstore tenant will not be visible in the original local user tenant

If you check plist/snippets, you will see that the tenant has been changed to reflect the LDAP user store name.

When LDAP userstore is activated, a tenant administrator can use the LDAP or original local userstore tenant to login but the data available will reflect the active userstore.

Environment

AXA 17.3

Resolution

To continue to see data under the LDAP tenant, the tenant needs to be updated in all mobile and browser monitoring, as well as any UIM probes or syslog configuration.

The old data is not lost, it can still be reviewed by reconfiguring the userstore to be the local userstore, but both options cannot be active at the same time.
There is no way to see the data from both tenants simultaneously through the product itself.

It is therefore strongly recommended to configure LDAP as early as possible in the AXA deployment to avoid reconfiguring tenant information and to have as much historical data in the same place as possible.