problem login to SOI after fail over to secondary manager server

book

Article ID: 129454

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

Unable to login to SOIUI after failing over the cluster node from active to passive

Cause

- The SOI manager java process was still running on the cluster node the manager was failed from
- DbAvailHistory, DbRiskHistory and DbQualityHistory each had around 400 million rows of data.

Environment

Release: SAMBDL99000-4.2-Spectrum-Service Assurance Manager-Promotional Bundle
Component:

Resolution

- From cluster manager offline all SOI services and killed the java process on the passive node
- Used SQL scripts from KB000129125 to purge the data
- Also ran following queries to purge data
  delete from CIHealth where endPeriod is null and CIID not in (select CIID from CI where ClassID=5) 
  delete from CIRisk where endPeriod is null and CIID not in (select CIID from CI where ClassID=5) 
  delete from CIQuality where endPeriod is null and CIID not in (select CIID from CI where ClassID=5) 

  delete from DbAvailHistory where ServiceID not in (select CIID from CI where ClassID=5) 
  delete from DbRiskHistory where ServiceID not in (select CIID from CI where ClassID=5) 
  delete from DbQualityHistory where ServiceID not in (select CIID from CI where ClassID=5) 
- From cluster manager online all SOI services