HTTP Status 400 received when attempting to open attachments after upgrading

book

Article ID: 129210

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

After upgrading CA Service Desk Manager from 12.9 to 17.1, although we are able to open ticket attachments that were created after the upgrade,  when attempting to open ticket attachments that existed before the update, the following error is returned:

HTTP Status 400 - Wrong redirection type Status report message Wrong redirection description The request sent by the client was syntactically incorrect. Apache Tomcat/8.5.6

Cause

The content of the "attachments" subdirectory under $NX_ROOT\site was moved out from under $NX_ROOT before you ran the installer and all of the files were not restored.

Environment

CA Service Desk Manager 17.1

Resolution

Check that the attachments folders that exists in the pre-upgraded system are in sync with the folders in the upgraded system.  Copy anything that is missing from your pre-upgrade archives or snapshot.