HTTP Status 400 received when attempting to open/download attachments from existing tickets after upgrade
search cancel

HTTP Status 400 received when attempting to open/download attachments from existing tickets after upgrade

book

Article ID: 129210

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

After upgrading CA Service Desk Manager we could open ticket attachments that were created after the upgrade.  When attempting to open ticket attachments that existed before the update, the following error is returned:

HTTP Status 400 - Bad Request

Type status report

Message - Wrong redirection

Description - The request sent by the client was syntactically incorrect. Apache Tomcat/8.5.x or similar

Environment

CA Service Desk Manager 17.x

Cause

The contents of the "attachments" subdirectory under $NX_ROOT\site were moved from $NX_ROOT prior to running the installer and its files were not restored.

Resolution

Verify that the attachments folders located in the pre-upgraded system are in sync with the folders in the upgraded system. 

Copy anything that is missing from your pre-upgrade archives or snapshot. 

Attachments