Release 9.0 started showing QnA failed attempts as -2

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Article ID: 129199

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Updated On:

Products

CA Rapid App Security CA Advanced Authentication CA API Gateway

Issue/Introduction

Description
Within the QNA section of 'Manage Authentication Credentials' of Admin UI, some users may have a "Number of Failed Attempts = -2". This issue was introduced in 9.0.  The CA Strong Authentication Reports may also show the same issue. 

 

Cause

Root Cause Of The Issue:

To distinguish the abandoned/incomplete transactions from the successful/completed transactions, code started assigning "-2" to "Failed Attempts" field in the Reports, instead of "0".

Environment

CA Strong Authentication Release 9.0. 

Resolution

Fix for the issue:

While displaying the field value for "Number of Failed Attempts" column in Reports and on the "Manage Credential" screen, the code is replacing "-2" with a "0", as it was the case in previous releases.

A hot fix exists at version 9.0 - CA-StrongAuth-9.0-DE392185-HotFix.zip. Please reach out to Broadcom Support for Advanced Authentication for this hot fix. 

Additional Information

None.