Upgrade fails on inserting lookup with java.lang.ArrayIndexOutOfBoundsException
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Upgrade fails on inserting lookup with java.lang.ArrayIndexOutOfBoundsException

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Article ID: 129073

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Upgrade fails on inserting a lookup (can be any lookup):
3/08/19 8:04 PM (ExecTask) Error Applying XOG: Failure occurred while applying RQP_BROWSE_INVESTMENTS_LOOKUP.xml
3/08/19 8:04 PM (ExecTask)  Check Home Directory/logs/xog-seeddata/out/database/RQP_BROWSE_INVESTMENTS_LOOKUP_out.xml for errors
3/08/19 8:04 PM (ExecTask) Home Directory/.setup/scripts/db.xml:2352: The following error occurred while executing this line:
3/08/19 8:04 PM (ExecTask) Home Directory/.setup/scripts/db.xml:2568: The following error occurred while executing this line:
3/08/19 8:04 PM (ExecTask) Home Directory/.setup/scripts/db.macros.xml:105: Java returned: 2

Checking the out file:
Error:
java.lang.ArrayIndexOutOfBoundsException: 0
at com.niku.odf.ori.service.DynamicLookupService.updateNsql(DynamicLookupService.java:212)
at com.niku.odf.ori.OdfEngine.importDynamicLookup(OdfEngine.java:2172)
at com.niku.odf.ori.xblhandlers.LookupsXogImportHandler.updateDynamicLookup(LookupsXogImportHandler.java:350)
at com.niku.odf.ori.xblhandlers.LookupsXogImportHandler.updateLookup(LookupsXogImportHandler.java:311)
at com.niku.odf.ori.xblhandlers.LookupsXogImportHandler.processXogRequest(LookupsXogImportHandler.java:164)
at com.niku.odf.ori.xblhandlers.LookupsXogImportHandler.postProcess(LookupsXogImportHandler.java:106)
at com.niku.xql2.XQLVisitor.postProcess(XQLVisitor.java:1416)

Environment

Release: CODFSS99000-15.4.1-PPM SAAS FedRAMP-Sandbox-Small Environment
Component:

Cause

Lookup is no longer present on the database

SQL query used to check:
select * from cmn_list_of_values clov, cmn_nsql_queries cnq
where clov.sql_text_id = cnq.id
and lookup_type_code ='RQP_BROWSE_INVESTMENTS'

If rolled back already, try opening the lookup and accessing the dynamic SQL, as that may give an error as well.

Resolution

1. Rollback to previous environment or installed checkpoint
2. Ensure the lookup is there (insert from another environment if needed by XOG)
3. Stop services and re-start the upgrade