Trigger Error when creating Change Orders or updating workflows
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Trigger Error when creating Change Orders or updating workflows

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Article ID: 128999

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

SDM stdlogs show an error like this:

02/22 11:28:45.36 SDMServer domsrvr 9824 ERROR where.y 908 Parse error at : "( service_type.id = AND object_type = 'wf' ) AND ( delete_flag = 0 )" (syntax error) 

02/22 11:28:45.36 SDMServer spelsrvr 6936 ERROR pdm_misc.pm 106 Error finding slatpl's with wc 'service_type.id = AND object_type = 'wf'' AHD03053:Bad where clause: Parse error at : "( service_type.id = AND object_type = 'wf' ) AND ( delete_flag = 0 )" (syntax error) 

02/22 11:28:45.36 SDMServer spelsrvr 6936 ERROR wf.spl 2971 Error with attached_sla_processing! 1 on failed: 

02/22 11:28:45.36 SDMServer web:local 9660 ERROR freeaccess.spl 25709 create checkin of chg:8339921 failed: Trigger Error 

Environment

Release:  17,3 or higher
Component: CA Service Desk Manager

Cause

1) Identify the Change Category to which the Change Order in question belongs to
2) Verify if the Category has any Workflow Tasks associated to it.
3) For each Workflow task there, check the details of that task to verify if there is a Service Type attached to it.
4) For the Workflow tasks with Service Type on them, verify if that Service Type itself has any SLA Template attached it.

Such Service Type not having an SLA Template causes the error.

Resolution

To resolve the issue, either
a) remove the Service Type from the Workflow Task, or
b) create an SLA Template against the Service Type