Error "Cannot obtain signatures or intellisigs from server"
search cancel

Error "Cannot obtain signatures or intellisigs from server"

book

Article ID: 128881

calendar_today

Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Software inventory collect task is in status ERROR.

In AM Agent logs following error appears :

amagent|SVCSPECS.CPP|000463|INFO   | Perform actual software inv. work based on the accumulated configuration.
amagent|SVCSPECS.CPP|000463|INFO   | Filescan disabled. Will not launch amisww32.exe.
amagent|SVCSPECS.CPP|000463|INFO   | Signature-based software scan enabled.
amagent|SVCSPECS.CPP|000463|INFO   | Signature scan not configured for this task
amagent|SVCSPECS.CPP|000463|INFO   | Intellisig scan not configured for this task
amagent|SVCSPECS.CPP|000562|ERROR  | Cannot obtain signatures or intellisigs from server. Aborting signature-based software scan.

Environment

Client Automation - All versions

Cause

This problem occurs if there are 2 Software inventory collect tasks assigned to a machine :
 

- One for Signature scan without intellisig scan
- One for intellisig scan without Signature Scan.


In below example there are 2 Software Discovery collect tasks linked to one computer.
One is for intellisig scan (Signature scan is not checked).
One is for Signature scan (intellisig scan is not checked).
 

Resolution

Merge the 2 Software inventory collect tasks into a single Software inventory collect task for both Signature Scan and Intellisig scan and link only this one to the computers.

Attachments