CA JCLCheck message CAY6077E on UNIT=DISK and UNIT=3390

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Article ID: 128878

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Updated On:

Products

CA JCLCheck Workload Automation

Issue/Introduction

Sample DD statement: 
//DATA1   DD  DSN=data.set.name,UNIT=3390,DISP=(,CATLG),  
//    SPACE=(CYL,(200,25),RLSE) 


CA JCLCheck returns error message:
CAY6077E NO "3390" UNITS ARE AVAILABLE FOR "data set name"

Same error is issued when UNIT=DISK is used. 
CA Allocate is enabled. 

 

Cause

CA Allocate does not participate in the JCLCheck allocation simulation because there is no interface between the two products.  
CA JCLCheck issues allocation errors  but the job actually runs fine because CA Allocate changes the allocation request on the fly.

Environment

CA JCLCheck 
CA Allocate

Resolution

  •  Reduce the severity level of message CAY6077 to a Warning or Informational
  •  Suppress message CAY6077.

Additional Information

- CA JCLCheck WA Message Control Option to change severity levels for messages:
https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=25210

- Modify CA JCLCheck Workload Automation error message severity level using a REXX exec:
https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=24107