SSO Portal Authentication stopped working again in dev and never worked on production
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Article ID: 128873
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Updated On:
Products
CA API Developer PortalCA API Gateway
Issue/Introduction
We recently updated certificates and switch from the deprecated SSO SAML authentication to new SAML authentication. It was working a week ago in dev but never in production
Cause
Service Provider ID did not match exactly what was configure as the service provider from ADFS
Environment
On-Prem gateway 9.3 SaaS Portal 4.2.10
Resolution
When configuring SAML Authentication click “Provider Configuration”
Service Provider ID
https://servername.mycompany.com
“Specify the service provider identification that identifies the CA API Portal service”
Value MUST match identical to the service provide defined this needs to include trailing slashes if they exist