SSO Portal Authentication stopped working again in dev and never worked on production
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SSO Portal Authentication stopped working again in dev and never worked on production

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Article ID: 128873

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Updated On:

Products

CA API Developer Portal CA API Gateway

Issue/Introduction

After updating certificates and switching from the deprecated SSO SAML authentication to new SAML authentication, authentication is failing. It was working a week ago in Dev and never worked in Production.

Environment

On-Prem gateway 9.3
SaaS Portal 4.2.10
 

Cause

The Service Provider ID did not match exactly with what was configured as the service provider from ADFS.


 

Resolution

When configuring SAML Authentication click  “Provider Configuration”
Service Provider ID
https://servername.example.com
“Specify the service provider identification that identifies the CA API Portal service”
 
The Value MUST must be identical to the service provider defined - this needs to include trailing slashes if they exist
 
Pre-prod https://servername.dev.example.com = worked
Prod https://servername.prod.example.com = failed with exception on portal with Null attributes

 

Production trailing slash was defined to fix changed
https://servername.prod.example.com
To
https://servername.prod.example.com/