Data Collector trying to do a fresh install rather than upgrade
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Data Collector trying to do a fresh install rather than upgrade

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Article ID: 128567

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Updated On:

Products

CA Performance Management Network Observability

Issue/Introduction

While upgrading the data collector prompts for a fresh install, and not an upgrade.

During a Data Collector upgrade, when entering the custom home directory the current install lives in the installer returns a message "The install folder you select already exists. Please choose a different location". Why won't it upgrade in the existing custom home directory?

Environment

All supported DX NetOps Performance Management releases

Cause

The /opt/DCM.cfg file is not found on the Data Collector server.

Resolution

The install looks for an /opt/DCM.cfg file to be present to detect an existing upgrade. If this file is missing, the installer will prompt as if this is a fresh install.

If the /opt/DCM.cfg file has been moved to a different location ensure it contains the correct information and move it back to the /opt directory. Run the upgrade again.

If the file is missing the fastest path to resolution is uninstalling and reinstalling the DC. This is a simple process documented in the Reinstall or Migrate the Data Collectors documentation topic.