API-1029 Error when using REST API
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API-1029 Error when using REST API

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Article ID: 12828

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Upon login, the error is given: API-1029 : Authentication Error

Environment

Release: All
Component: Clarity Security Access Administration

Cause

This error occurs when a user is missing an access right.

Resolution

  1. Make sure the environment does not have REST API Access disabled
    • Go to CSA > Server Properties > Application > Application Server.
    • 'Disable REST API Access' should be unchecked.
  2. Ensure the user has global right: API - Access

Additional Information

Note: This access should only be provided to users needing access to REST API. 

Also check KB DE56355 New UX: User without the API - Access permission is getting API-1029 : Authentication Error after timeout