Error "Failed to import the content" while installing Service Catalog

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Article ID: 128053

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Updated On:

Products

CA Service Catalog CA Service Management - Service Desk Manager

Issue/Introduction

Service Catalog and SDM have a shared MDB and both were upgraded to 17.1.

When using Setup Utility to finish Catalog's upgrade, in the component section fails with error "Failed to import the content":


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Cause

Reviewing "seeddata.log" file, the following error appears while the import procedure is executed:

 ERROR Exception while communicating with the database:The ALTER TABLE statement conflicted with the FOREIGN KEY constraint "XFKusm_contact_domain_role1". The conflict occurred in database "mdb", table "dbo.usm_tenant_ext", column 'tenant_id'.
com.microsoft.sqlserver.jdbc.SQLServerException: The ALTER TABLE statement conflicted with the FOREIGN KEY constraint "XFKusm_contact_domain_role1". The conflict occurred in database "mdb", table "dbo.usm_tenant_ext", column 'tenant_id'.

This means that table "usm_runtime_component" is empty, causing that the constraint can't be completed bu the installer. This can be reviewed with the following query:

SELECT * FROM usm_runtime_component

Environment

Service Catalog 17.1

Resolution

In order to solve the issue, this table must have data in it, with the following query a line can be added to solve this issue:

INSERT INTO usm_runtime_component
VALUES ('Scheduler',NULL,NULL,NULL,NULL,NULL)


After this the component deployment can be re attempted.

If for any reason the deployment doesn't start, with the following steps the Setup Utility can be re initialized:

https://comm.support.ca.com/kb/How-to-redeploy-the-CA-Service-Catalog-Components-through-the-CA-Service-Catalog-setup-utility/KB000030138

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