Clarity PPM: APP and BG services fail to start after upgrade to 15.5.1
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Article ID: 128033
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Updated On:
Products
CLARITY PPM FOR ITGCLARITY PPM FEDERALClarity PPM SaaS - ApplicationClarity PPM On Premise
Issue/Introduction
The following appears as the app and/or bg service tries to start. “ Starting Niku Server [app]... Waiting for Niku Server [app]...................... ....WARNING: Niku Server [app] may have failed to start. Starting CA PPM Background Server [bg]... Waiting for CA PPM Background Server [bg]...................... ..WARNING: CA PPM Background Server [bg] may have failed to start. “
Cause
This is due to an invalid JVM parameter list entered in the CSA / properties.xml fille.
Environment
Release: Component: PPMPRD
Resolution
Review the corresponding app-system.log or bg-system.log to find out the exact error.
1. Make a copy of the properties.xml file. 2. Remove the invalid parameter specified in the app-system.log or bg-system.log. 3. Restart NSA and affected app/bg service to see if problem persists. 4. Repeat as necessary until the service starts.
Note: The following example of the JVM parameter list will work: -Xms512m -Xmx2048m -XX:-UseGCOverheadLimit -DforceMemorySettings=false -XX:MaxMetaspaceSize=300m