The following message appears in the logs "SQL parse error: Column ebr_serial_num not found in table Call_Req (subquery 1.0 SELECTION) at . ebr_serial_num" And SDM starts working slowly

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Article ID: 127982

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Updated On:

Products

CA Service Management - Service Desk Manager ServiceDesk

Issue/Introduction

Service Desk Manager works slowly and experience performance issues. The following  appears in the logs:

bpvirtdb_srvr  11332 ERROR        sqltrans.c            2156 Column ebr_serial_num not found in table Call_Req (subquery 1.0 SELECTION)
bpvirtdb_srvr  11332 ERROR        vdbsql.c              4619 SQL parse error: Column ebr_serial_num not found in table Call_Req (subquery 1.0 SELECTION) at . ebr_serial_num
bpvirtdb_srvr  11332 SIGNIFICANT  vdbsql.c              4620 SELECT Call_Req.open_date,Call_Req.id,min(Attached_SLA.time_to_violation) AS mintime,min(target_time.target_time) AS mintgt,Call_Req.ref_num,Call_Req.last_mod_dt,Call_Req.summary,Call_Req.zsua,Call_Req.ebr_serial_num FROM Call_Req WHERE Call_Req.type = 'R' AND Call_Req.ref_num = '5975019'  OUTER_JOIN Call_Req.persid = Attached_SLA._mapped_cr ; Call_Req.persid = target

Cause

Defect with 14.1
This issue was addressed via T52Y539 (USRD2793) in SDM 14.1.02.

Environment

Service Desk Manager (SDM) 17.2

Resolution

For release r17.2 we are still in the process of analyzing evidence so that we can confirm that this is the same problem.
If confirmed that this is the same problem then the fix that was created and delivery on r14.1.02, will be ported to serve customers on release r17.2.

If you are experiencing this behavior please open a case in support informing you about this article, and attaching to the case the following information to assist in our investigation:

Enable the following trace/processes in your environment:
pdm_trace bpvirtdb_srvr on
pdm_trace bpvirtdb_srvr size 100000
pdm_trace bpvirtdb_srvr watch sqltrans.c 2156
pdm_trace bpvirtdb_srvr attach domsrvr
pdm_trace domsrvr size 100000

Traces should be written automatically due to the watch setting.
Monitor the environment for at least one day. As soon as the slow-process starts please write down the time so that we can be more assertive in our analysis of traces.

To turn off trace, including attached processes, run:
pdm_trace bpvirtdb_srvr off

Collect pdm_trace for domsrvr and bpvirtdb_srvr and stdlog files and attach to the case open in the stand.