Agile Central - On-premises: ALM will not start after configuring LDAP
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Agile Central - On-premises: ALM will not start after configuring LDAP

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Article ID: 127954

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Updated On:

Products

Rally On-Premise

Issue/Introduction

After configuring LDAP in the control panel and restarting the services, the Agile Central services will no longer start up.
One of the  following errors is observed in the startup.log in /home/appuser/domains/alm/logs/
sh: -DLDAP_URL=ldap://onprem-ad1.rallyonprem.local:389: No such file or directory
2019-02-25 12:25:40 -0700-INFO: Connection refused - connect(2) for "localhost" port 7001. Retries exhausted.
2019-02-25 12:25:40 -0700-ERROR: Java process failed to start correctly!
- or -

Error: Could not find or load main class Admin,CN=Users,DC=rallyonprem,DC=local

Environment

Release: ACNQMG99000-2016-Agile Central-Quality Manager-Perpetual
Component:

Cause

There can be two causes for this
  1. This can be caused by using certain special characters in the LDAP user password.  Characters that need to be avoided are the greater than symbol (>) and the pipe symbol (|).
  2. Using quote (") characters in the Bind Username DN field

Resolution

  1. Update the password being used for LDAP connectivity so that it does not contain the special characters > or |
  2. Remove the quotes from the Bind Username DN field