This article provides instructions for resolving "SQLException occurred: A duplicate key violation has occurred" errors when creating or saving workflow processes in Identity Manager. This error typically occurs when Workpoint database IDs are out of synchronization.
Identity Manager 14.5
During the initial product installation, the Workpoint database is initialized with default identifiers. Importing the base workflow archive can lead to ID collisions if the existing IDs are not synchronized to the current maximum value in the database.
To resolve this synchronization issue, use the IdCheck tool to resync the Workpoint Database identifier.
IdCheck.bat file located in the Identity Manager tools directory.IdCheck.bat file are accurate for your environment.IdCheck.bat from the command line to resync the database identifiers.To speak with a customer representative or a Support Engineer see . Scroll to the bottom of the page and click on your respective region.