SDM: Upgrade/Migration shows Debug Error and HEAP CORRUPTION on sql_check_db.exe

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Article ID: 127860

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Working to migrate or upgrade Service Desk.  During the "Migrating CA Service Desk Manager" step, experiencing the following Microsoft Visual C++ Debug Library "Debug Error" mentioning a HEAP CORRUPTION DETECTED message on sql_check_db.exe



The checkdb.0 logs presents:
01/01 12:00:00.00 SERVER1   sql_ckeckdb          6964 ERROR        encrypt.cpp            520 etpki_lib_init return -1
01/01 12:00:00.00 SERVER1   sql_ckeckdb          6964 ERROR        encrypt.cpp            139 unable to initialise encryption operation

Cause

The CAPKI might not have been installed correctly. The CAPKI is the CA Public key Infrastructure that is used across the various CA product line to facilitate inter-product security.  It is a separate component that is used exclusively by CA

Environment

CA Service Desk Manager (migration/upgrade activity)

Resolution

Run the following on the affected server on an Admin Command prompt (right click on Command Prompt and choose to "Run As Administrator").

nxcd add-ons\etpki

setup.exe install caller=CASDr12 verbose instdir="C:\Program Files (x86)\CA\SC\CAPKI"


The above path may need to be changed on the "C:\Program Files (x86)\CA\SC" side in order to put on CAPKI.

Once CAKPKI install is corrected, re-run the installer.

Additional Information

Information on CAPKI is available here:
https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=13943

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