Probes are not displayed when expanding the robot node in IM

book

Article ID: 127850

calendar_today

Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

Probe list is not displayed in the right pane when expanding the robot node in the Infrastructure Manager

When selecting the robot in the Admin Console, displays an error:

"Failed to retrieve information for robot at domain/hub/robot" 
" Failed to retrieve information about robot at domain/hub/robot/controller" 

A reboot of nimbus robot watcher service will temporarily fix the issue on this robot, but the same issue could happen on a different robot.

In the hub log, found intermittent errors:

Apr 4 15:53:54:128 [3792] hub: nametoip - /domian/hub/robot xx.xx.xx.xx/50000 - 0 ms (nns) 
... 
Apr 4 15:55:19:383 [1920] hub: nametoip - /domian/hub/robotcontroller not found 
Apr 4 15:55:19:383 [1920] hub: TSESS-P-291783-5 name to IP failed for /domian/hub/robot/controller (not found) 
... 
Apr 4 15:59:01:517 [1052] hub: nametoip - /domian/hub/robot xx.xx.xx.xx/50000 - 0 ms (nns) 
... 
Apr 4 16:00:09:256 [5728] hub: nametoip - /domian/hub/robot/controller not found 
Apr 4 16:00:09:256 [5728] hub: TSESS-P-291878-4 name to IP failed for /domian/hub/robotcontroller (not found) 
... 
Apr 4 16:09:05:264 [3196] hub: nametoip - /domian/hub/robot xx.xx.xx.xx/50000 - 0 ms (nns) 

Environment

Release:
Component: UIMHUB

Resolution


- Deploy Microsoft Visual C++ 2008 Redistributable Package to the hub robot.
https://www.microsoft.com/en-us/download/details.aspx?id=29

- Deploy robot_update 9.x and hub 9.x to the hub robot.

- On the IM, select the Hub then press shift and right-click on the hub probe then Set 'cache_remote_nametoip = no'.


- Repeat the above steps on all hub robots.

Attachments