new users cannot be added in USS in the first login

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Article ID: 127808

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Some new users (pre-existing in Service Desk Manager as a valid contact) are not able to be created in the USS "User_" table by the first login in USS UI. Even if they try to manually add them in USS, they get the message:

"Enter a valid ScreenName"

Cause

For some reason, there were groups created in "Group_" table with the groupid equals to the userid (Screen_Name) that customer was trying to insert. So, it was causing a conflict and users could not be inserted.

In the example:
​​​​​​
     User: Daiana (userid/screenname: "0038258") 

We noticed that there was a group created with groupid = "0038258", and so on for the other no working users.

Environment

Service Management 17.1.02
Service Desk Manager / Service Catalog / Unified Self-Service

Resolution

They removed those useless groups and after some time, they were able to add those users successfully.