Pdm_k_reindex fails due to critical error

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Article ID: 127805

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When running pdm_k_reindex an error is received:

"The pdm_k_reindex utility did not end successfully due to a critical error. Please see the stdlog file for further details. After resolving the problem please run the pdm_k_reindex utiltity again."

Review of stdlog may show:
 
sqlagt:CREATE_IND    3168 ERROR        sql_common.c           323 CREATE INDEX returned 11  [Microsoft SQL Server Native Client 11.0] [ SQL Code=0 SQL State=08S01] Communication link failure

sqlagt:CREATE_IND    3168 ERROR        sql_common.c           324 CREATE UNIQUE INDEX "ebr_fulltext_adm_x0" ON "ebr_fulltext_adm" ( "id"                         ASC )
sqlagt:CREATE_IND    3168 ERROR        sqlsrvr.c              651 Execution failed. MISC_DB_ERROR

bpvirtdb_srvr        4032 ERROR        vdbsql.c              5791 CREATE INDEX agent got database error 15

Cause

This may be caused by a communication error with the database server. The system may have been able to mostly recover from the error, but the knowledge index cache may get out of sync.

Environment

Release:
Component: USRD

Resolution

1. Stop the Service Desk services completely 
2. Go into the Service Desk install folder, then open the "site" folder. There should be two folders in there, "ebr" and "ebr_ADM", remove these two folders from the directory 
3. Start Service Desk services, and run the pdm_k_reindex command, it may take a bit of time to completely rebuild the index depending on the number of documents in the environment