Migrate_to_r14_1.pl missing when upgrading CA Service Desk from 12.9 to 17.1

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Article ID: 127790

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Messages from install.log:

DEBUG [stdout( D:\CA\SERVIC~1\bin\pdm_perl.exe):Thread-30] [MigrateSDM] Can't open perl script "migrate_to_r14_1.pl": No such file or directory
INFO [DeployThread: Migrating CA Service Desk Manager] [ProcessUtilities] Process D:\CA\SERVIC~1\bin\pdm_perl.exe completed with exit code 2
INFO [Thread-29] [ProgressUpdateMigrateSDM] Waiting for migration log to be available. retry 1 of 50
INFO [Thread-29] [ProgressUpdateMigrateSDM] Waiting for migration log to be available. retry 50 of 50
INFO [Thread-29] [ProgressUpdateMigrateSDM] Waiting for migration log to be available. retry 51 of 50

Cause

It happens when the installer does not have enough disk space for making a backup of NX_ROOT folder.

Basically an upgrade would do:

1) Backup NX_ROOT (Zipping NX_ROOT, uses %TEMP%);
2) Upgrade CA Service Desk software;
3) Restore some files;
4) Upgrade MDB, do migrate, configure etc.

If the first step somehow did not go through properly,  the Step #2 doesn't go well either and so you have missing files etc.

Environment

CA Service Desk 17.1
CA Service Desk 17.0
CA Service Desk 14.1

Resolution

Make sure you have enough disk space for copying the entire NX_ROOT folder (pay attention to NX_ROOT\site\attachments).