Error on Update Catalog Rollup 2 patch - Unable to encrypt/decrypt SLCM text

book

Article ID: 127763

calendar_today

Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When running the setup procedure to apply the Service catalog Rollup Patch 2, the installer don't show option to select oracle database in database configuration.
He gets the following error if he tries to continue with the patch installation:

2019/01/08 17.48.41.430 ERROR [main] [SLCMEncrypter] Unable to encrypt/decrypt SLCM text 2019/01/08 17.48.41.430 ERROR [main] [CurrentVersionDiscoverer] Failed to initialize Database

Cause

The problem was due to the DBSource.password parameter from config.properties.
For some reason, the password was not possible to be decripted and the problem occurred.

Environment

Service Catalog 17.1.02

Resolution

Customer replaced the config.properties file from C:\Program Files\CA\Service Catalog, with one from a working environment and the RUP2 intallatioin was successfully applied