Statemanager fails to connect with Riskfort in a LoadBalanced environment
search cancel

Statemanager fails to connect with Riskfort in a LoadBalanced environment

book

Article ID: 127540

calendar_today

Updated On:

Products

CA Rapid App Security CA Advanced Authentication CA API Gateway

Issue/Introduction

Statemanager reports issues when trying to connect to Riskfort server for Risk Evaluation function. The arcotsm.log shows the footprints below on each unsuccessful connection fail over attempt. Note in the example below the issue has occurred 9 times as indicated by -  "connectionfailures : 9"

2019-02-17 00:00:38,317 [http-nio-8080-exec-9] INFO core.pool.PoolManager(243) -> Detected fail over scenario! (Num of connectionfailures : 9) 
2019-02-17 00:00:38,317 [http-nio-8080-exec-9] WARN core.pool.PoolManager(134) -> Exception occurred while borrowing object 
ErrCode:8::Message:No active pool was found. 

 

Environment

CA Strong Authentication Environment (specifically CA Statemanager and CA Riskfort server communication)

Cause

Root cause
Load-Balancer IP change over a period of time and the SDK lacked the capability to use latest destination IP addresses while creating a new socket.

 

Resolution

Upgrade to 9.0.02 version or request CA-Adapter-9.0.02-DE405875-Devfix.zip from Broadcom Support. This was a development version of the patch. The official version of the patch will be shared shortly.

Additional Information

None