EEM CA Directory iTechPoz service cannot start by Error 13 The data is invalid

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Article ID: 127538

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

The service name is "CA Directory - iTechPoz-servername"  cannot be started.
The error message from the iTechPoz service is "Error 13: The data is invalid" 

Cause

The Itechpoz file inside the folder: C:\Program Files\CA\Directory\dxserver\pid is corrupted

Environment

CA Embedded Entitlement Manager 12.5

Resolution

Steps to fix the problem:

1. Open a command prompt(as administrator) window and type:
dxserver stop all

2. Then go to %DXHOME%\pid
Default path: (C:\Program Files\CA\Directory\dxserver\pid)
-Remove any files that are in that location (you can make a copy before removing the files)

3. Then start the itechpoz, type the following:
dxserver start all

4. Check the 'services' > Running now.

Additional Information

To help with the investigatin, I'd recommend to review the basic EEM logs: (ipoz.log, igateway.log, ldap.log, server.log etc)