TDMJobEngine-JobCleanupHelper failing jobs deleted manually GTREP.QRTZ_TRIGGER_TO_JOBS_FK

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Article ID: 127282

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

The following error message occurs when the system tries to clean up the old Jobs queue:

constraint [GTREP.QRTZ_TRIGGER_TO_JOBS_FK]; nested exception is org.hibernate.exception.ConstraintViolationException: could not execute statement 

2019-02-14 16:33:02.472 UTC [INFO ] [pool-13-thread-1 ] --- [U:][M:][P:] c.c.t.j.s.JobCleaner: Starting the job cleanup process... 
2019-02-14 16:33:02.491 UTC [INFO ] [pool-13-thread-1 ] --- [U:][M:][P:] c.c.t.j.s.JobCleaner: Number of jobs to cleanup: 34 
2019-02-14 16:33:02.491 UTC [INFO ] [pool-13-thread-1 ] --- [U:][M:][P:] c.c.t.j.s.JobCleaner: Number of iterations to cleanup: 1 with Batch size: 500...... 

2019-02-14 16:33:03.773 UTC [WARN ] [pool-13-thread-1 ] --- [U:][M:][P:] o.h.e.j.s.SqlExceptionHelper: SQL Error: 2292, SQLState: 23000 
2019-02-14 16:33:03.773 UTC [ERROR] [pool-13-thread-1 ] --- [U:][M:][P:] o.h.e.j.s.SqlExceptionHelper: ORA-02292: integrity constraint (GTREP.QRTZ_TRIGGER_TO_JOBS_FK) violated - child record found 

2019-02-14 16:33:03.811 UTC [INFO ] [pool-13-thread-1 ] --- [U:][M:][P:] o.h.e.j.b.i.AbstractBatchImpl: HHH000010: On release of batch it still contained JDBC statements 
2019-02-14 16:33:03.837 UTC [ERROR] [pool-13-thread-1 ] --- [U:][M:][P:] c.c.t.j.s.JobCleaner: Error while cleaning up the job data in iteration : 1... 
java.sql.SQLIntegrityConstraintViolationException: ORA-02292: integrity constraint (GTREP.QRTZ_TRIGGER_TO_JOBS_FK) violated - child record found

Cause

Certain corner cases need to be accounted for.

Environment

TDM Web Portal 4.7

Resolution

We are in the process of improving the job cleanup process. I would suggest to provide a dump of the quartz tables (QRTZ_JOB_DETAILS, QRTZ_SIMPLE_TRIGGERS, QRTZ_TRIGGERS) as well as the jobengine log in debug mode.

To get over the error message, make sure that no jobs are running. stop portal service and empty the tables (QRTZ_JOB_DETAILS, QRTZ_SIMPLE_TRIGGERS, QRTZ_TRIGGERS)

Additional Information

Video URL on how to open a Support Case - https://communities.ca.com/videos/5898-demo-how-to-open-a-support-case
You can download the latest version of TDM by following the directions in this document: https://comm.support.ca.com/kb/How-to-Download-Test-Data-Manager/KB000009671.    
To contact support, go to https://www.ca.com/us/services-support/ca-support/contact-support.html