Cannot inactivate CI - Error cmdb_ext_check_inactive:0900 Insert/Update rejected because this CI is inactive/superseded

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Article ID: 127182

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When trying to inactivate a configuration item (CI) it returned the error message below: cmdb_ext_check_inactive:0900 Insert/Update rejected because this CI is inactive/superseded Verified in the tool and there is no constraints with this message, so I believe it is a default message. Researching this error I could not locate any documentation that inform anything about this; could you let me know or provide any documentation about this error?

Cause

There are some SDM options under Options Manager >> CA CMDB installed but having "No" value defined by default which are preventing these actions.

Environment

CA Service Desk Manager 14.x / 17.1

Resolution

Log into CA Service Desk Manager (SDM) as Administrator, then navigate to the "Options Manager >> CA CMDB" under Administration tab.

Change the values from "No" to "Yes" for the two below options:

    allow_updates_to_inactive_ci
    allow_updates_to_superseded_ci

Recycle SDM service and make sure the values are reflected in NX.ENV file as below:

@NX_ALLOW_UPDATES_TO_INACTIVE_CI=Yes
@NX_ALLOW_UPDATES_TO_SUPERSEDED_CI=Yes

Additional Information

Note to follow the modifications from Options Manager according the documentation:

CA Service Management - 17.1 >> Administering >> Administering CA Service Desk Manager >> Options Manager >> Install/Uninstall Options Manager Options