CA Gen Web Java/C# Generation for Window Manger Failed
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Article ID: 127152
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Updated On:
Products
GenGen - Workstation ToolsetGen - Host EncyclopediaGen - Run Time Distributed
Issue/Introduction
Using an existing CA Gen model with Windows GUI clients. When migrating to a Web UI environment, although generation of Window Manager for WINDOWS/C is successful the generation of the corresponding JVM/Java or CLR/C# Window Manger shows "Failed" with this message: _________________________________________________________________________ Messages for the generation of <WINDOW MANAGER >
ICG: icm generation terminated. Unable to open file LoadModule.lst in the java subdirectory. _________________________________________________________________________
Alternatively the generator program ing.exe may actually crash and a dialog box "Web Client Generator has stopped working" is displayed The toolset does not crash but only shows: _________________________________________________________________________ Messages for the generation of <WINDOW MANAGER >
Cause
Typically some object on a Window or Dialog Box can cause the problem. The root cause is often related to having some changes made in a Window Design mode (Window / HTML/ ASP.Net) when "Common Edit Modifications" option has been disabled (default is enabled), so that the changes only apply for that mode and not all modes. Those changes create custom associations & custom objects in the model for the different modes.
Environment
CA Gen, any version.
Resolution
For the Window Manager in question manually inspect the Windows and Dialog Boxes for the corresponding Procedure Step(s). Check if what is shown in Window mode is the same as in the mode being generated i.e. mode HTML (JVM) or ASP.Net (CLR). If discrepancies are found which should not be there, with "Common Edit Modifications" enabled, delete the objects and then add them back so that all modes see the new objects (also see "Edit/Remove Customization" below). If that does not resolve the generation problem test deleting 1 field at a time to see if that will help find the root cause. Start with menu item fields which have been to show problems in the past. If the problem field can be found then try adding it back again with "Common Edit Modifications" enabled. If the problem still persists or further assistance is required please create a CA Gen support case to get assistance from Broadcom CA Gen Technical Support.