CA Infrastructure ManagementCA Infrastructure ManagementCA Performance Management - Usage and Administration
Issue/Introduction
Our new 3.6.2 build is not dispatching emails for some reason in our Production build. I've taken a sniffer trace on the console server that shows SMTP traffic absent to prove this out.
Our 2 other builds are working fine and I have a trace that shows the SMTP traffic.
Cause
The errors we see in the DMService.log
INFO | E-mail Job Scheduler-1 | 2019-02-13 11:57:44,226 | com.ca.im.portal.dm.scheduling.email.EmailJobScheduler | Sending emails for 1 job(s) that have been marked as 'run now' ERROR | EmailJobTaskThreadPool-Thread-2 | 2019-02-13 11:57:44,238 | com.ca.im.portal.dm.scheduling.email.EmailJobTask | Error sending e-mail: Connection refused (Connection refused) java.net.ConnectException: Connection refused (Connection refused) at java.net.PlainSocketImpl.socketConnect(Native Method)
would seem to indicate that the connections is being refused by the email server, but the sniffer trace (wireshark or tcpdump) shows no smtp traffic leaving the console.
Environment
CAPC 3.6.x on linux
Resolution
Collect RemoteEngineer output from the CAPC host or run SsoConfig.
Verify that all the settings are correct.
In this instance we saw that sso had a remote value set to https, but no other settings were https, so the error is actually pc trying to grab the pdf for mailing and sso is refusing to connect.
Reset the values in SsoConfig to the correct settings, http in this case.