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Error when opening Report via AWI

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Article ID: 127040

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When opening Job Output from the Directory tab (after an execution) or via Open Report, the following error is noticed:

k.core.exceptions.MLSInternationalizedException: No Agent available to process request

It doesn't appear as though the associated Agents were down, and the issue resolves on its own. 

Cause

This behavior is in error, and will be fixed with a future release. 

Environment

Affected component: Automic Web Interface v12 (12.0.x, 12.1.x, 12.2.x).

Resolution

This issue will be fixed in the following component/releases:

Automic Web Interface

12.3.0 - Planned release June 28th, 2019.
12.2.2 - Released. 
12.0.8 - Planned release May 6th, 2019.
12.1.5 - Planned release May 20th, 2019.

Additional Information

As a workaround for the error message, jobs may be configured so that the reports are saved to the database - this should avoid the message, but reports will be unavailable. This should have no effect on the job execution itself.