The reproduction procedure is as follows. 1. Start Client Manager 2. Select [File] - [Setup] 3. Specify "Dir.Svc.DLL" and "Dir.Svc.InputFile" and click the [OK] button 4. Select [File] - [Save] 5. Close the Client Manager once 6. Start the Client Manager again 7. Exit the Client Manager as it is 8. The above error is output to Windows Event Viewer
If the directory service is not used (that is, "Dir.Svc.DLL" is not specified in the above step 3), no error is output to the event viewer.
Environment
Gen 8.6 Client Manager Windows
Cause
Support also recreated similar Event Viewer error in-house on various machines with different versions of ucrtbase.dll. On some tests a dialog box "Client manager has stopped working" was also displayed on exit. After applying Windows updates which updated the version of that file the problem was resolved. So the error appears to be related to the version of ucrtbase.dll.
Resolution
The problem was resolved by Windows patch KB4284833 which updated ucrtbase.dll to 14393.2339.
It is not possible to prove that the version of the failing module ucrtbase.dll is the solution to this error, but from the patch install the error is resolved by updating the file.