12.8 SP2 Adminui UI Deployment Issue

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Article ID: 126761

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Updated On:

Products

CA Single Sign-On SITEMINDER

Issue/Introduction

The 12.8 SP2 Administrative UI, may fail to completely deploy. 
The server.log might show the following. 
 
ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3) MSC000001: Failed to start service
jboss.deployment.subunit."iam_siteminder.ear"."management_console.war".POST_MODULE: org.jboss.msc.service.StartException in service
jboss.deployment.subunit."iam_siteminder.ear"."management_console.war".POST_MODULE: JBAS018733: Failed to process phase POST_MODULE of subdeployment "management_console.war" of deployment "iam_siteminder.ear
or
Line 150: 2019-02-04 10:36:18,055 WARN [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry library/struts.jar in /home/cassodev/CA/siteminder/adminui/standalone/deployments/iam_siteminder.ear/iam_siteminder_wpServer.jar does not point to a valid jar for a Class-Path reference.

Cause

A defect in the installer package caused this issue for some customers. 

 

 

Environment

Administrative UI 12.8 SP2 install and upgrade use cases. 
All supported OS's.

Resolution

On February 25th 2019, an updated installer for the SSO Administrative UI as provided. 
Please review the following related information.

Minor change to the CA SSO R12.8.02 kit
https://ftpdocs.broadcom.com/phpdocs//7/5262/5262_Proactive%20Notice%2012_8_02%20UI%20Installer%20Change_Final%20CA%20Single%20Sign.pdf

- You need to upgrade the AdminUI, AdminUI, pre-req and Policy Server to
  12.8SP3 to get this issue solved.

  Find the binaries for 12.8SP3 on Windows here :

  Solution Document: SS09920

    adminui-12.8-sp03-win64.zip
    adminui-pre-req-12.8-sp03-win64.zip
    ps-12.8-sp03-win64.zip

  https://casupport.broadcom.com/download-center/solution-detail.html?aparNo=SS09920&os=ANY

Or

- Follow documentation instruction to make working the AdminUI 12.8SP2
  build 1992 :

  12.8.02 Administrative UI Deployment Fails

  https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-identity-and-access-management/single-sign-on/12-8/troubleshooting/administrative-ui-troubleshooting.html#concept.dita_666a2b1bdf3cf75c816907299333f561ec7aad5f_12802AdministrativeUIDeploymentFails