HQ119015: The connection was disconnected because of server shutdown [code=DISCONNECTED]"

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Article ID: 126723

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Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

Discovery server showing following warning "28 Jan 2019 12:23:38,679 [Thread-73 (HornetQ-client-global-threads-933869191)] WARN org.hornetq.core.client - HQ212037: Connection failure has been detected: HQ119015: The connection was disconnected because of server shutdown [code=DISCONNECTED]"

 

Cause

When the queue exceeds the threshold (queue_growth_size = 10 MB default), an alarm is sent.

Environment

Any UIM 8.x and 9.x

Resolution

Goto hub.cfg file, check for "queue_growth_size =" but the default is 10MB. This is the hub bulk warning in the hub.cfg Alarm on queue size - the size of the queue file (in MB) on the hub. If the queue exceeds this threshold, an alarm is sent.  As a best practice support suggest this value be raised to a minimum of 300. In large environments, this should usually be 500 - 750.

Additional Information

https://docops.ca.com/ca-unified-infrastructure-management-probes/ga/en/alphabetical-probe-articles/hub/hub-im-configuration/hub-im-gui-reference#HubIMGUIReference-GeneralAdvancedSettings