OneClick display is blank after OS patching

book

Article ID: 126443

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

After RH OS patching, the OneClick console does not completely open. We get the frame but no data in the frame. The OS patching that was done was: CentOS/RHEL/OEL 6 2.6.32-754.10.1 

Cause

There is a known issue in 10.2.3 where if a landscape was removed from the landscape map, some residual instance of the landscape may still exist in the SpectroSERVER database, and this causes Spectrum to get stuck in a loop searching for the missing landscape. The fact that this issue occurred after OS patching may be coincidental. The symptom of the OneClick Web page and Console not drawing properly may be due to user issues caused by the phantom missing landscape. 

The exception thrown in the Tomcat log can be lengthy. Two errors which give a clue are: 

UserModelDomainList: could not obtain the name for domain <landscape_handle>

SPC-OCC-10385: Error invoking the constructor for the context object: id "com.aprisma.web.security.GlobalAccessPrivilegeManager" at scope "global", class "com.aprisma.spectrum.app.web.security.GlobalAccessPrivilegeManager"

Environment

Spectrum 10.2.3
Linux OS

Resolution

The landscape cannot be manually removed from the database as the issue is internal. This is resolved with Spectrum_10.02.03.D361. The fix is also included in Spectrum 10.3. 

 

Additional Information

Please open a support case to obtain a copy of Spectrum_10.02.03.D361.