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Clarity PPM: When attempting to navigate to the project in the new UX, Receive Error "Could not load project"
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Article ID: 126299
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Updated On:
Products
Clarity PPM SaaSClarity PPM On Premise
Issue/Introduction
When attempting to to navigate to the project in the new User Experience (UX), Receive Error "Could not load project".
Steps to Reproduce: 1. Log In to a CA PPM with the new UX enabled 2. Go to Administration - Studio - Content Add-Ins - Accelerator: Program Management Office - Items 3. Filter to find the Status Report Object 4. Check the check box next to the object, click Install, and wait for the install to complete 5. Now go to New User Experience link 6. Navigate to a Project 7. Click on Project to open in new UX
Expected Results: Project opens successfully, no error message Actual Results: Error "Could not load project".
Cause
To confirm this is the cause of your issue, run the below query. If any results are returned, you can use the workaround below:
select * from odf_custom_attributes where object_name = 'cop_prj_statusrpt' and internal_name = 'cop_overall_status' and API_ALIAS is null;
Environment
PPM 15.5.1.240
Resolution
Workaround:
1. Take a backup of the ODF_CUSTOM_ATTRIBUTES Table:
Create Table ODF_CUSTOM_ATTRIBUTES_CA_BACK AS (Select * from ODF_CUSTOM_ATTRIBUTES) Commit;
2. Run the below query to change the attribute status: Update ODF_CUSTOM_ATTRIBUTES SET API_ALIAS = 'overallStatus' where OBJECT_NAME = 'cop_prj_statusrpt' and INTERNAL_NAME = 'cop_overall_status' and (API_ALIAS <> 'cop_overall_status' or API_ALIAS is null);
1 row should be updated Commit;
3. Restart the app services on the environment service stop app service start app